Bienvenido, Invitado
Recordarme

TEMA:

Missing Form workaround 13 años 7 meses antes #22

  • Autor del tema
  • TheMuffinMan
  • Invitado
  • Invitado
Problem: If you want to connect a form item to a menu item the url isn't right and that leads to the "Form not found" error. That problem is now on the roadmap, too.

Workaround:

Instead add an external link with this signature:

index.php?option=com_facileforms&ff_name=YOUR_FORM_NAME


Another nice possibility is to use the plugin with normal content. Just install and enable the BreezingForms plugin and in any content add this:

{FacileForms: YOUR_FORM_NAME}

Also see the plugin details for further parameter.

BUG is solved. Please upgrade!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Última Edición: Post by TheMuffinMan.

Re:Missing Form workaround 13 años 7 meses antes #147

TheMuffinMan wrote:

Problem: If you want to connect a form item to a menu item the url isn't right and that leads to the "Form not found" error. That problem is now on the roadmap, too.

Workaround:

Instead add an external link with this signature:

index.php?name=com_facileforms&ff_name=YOUR_FORM_NAME


Another nice possibility is to use the plugin with normal content. Just install and enable the BreezingForms plugin and in any content add this:

{FacileForms: YOUR_FORM_NAME}

Also see the plugin details for further parameter.


First thank you for your hard work. It is very good and helpful this extension. I would like to share some of my experience of use Breezing Forms so I can help to make the component better by feedback. Here is something I observed:

1. The problem with use "of external link" is that if "Search Engine Friendly URLs" are switched on, the page URL with Breezing Form does not look good in comparison with other pages URL.

2. I tried to use second method to show Breezing Form. So I switched on/enabled BreezinForms plugin and created static page/article which include "{FacileForms: YOUR_FORM_NAME}". Then I created menu link to this static content/article. And the Breezing Form appeared there correctly. But big problem was, that if BreezinForms plugin is enabled some other pages on my website stopped to work and displayed this error message: "Fatal error: Argument 2 passed to botFacileForms() must be an object of class JParameter in /var/www/web5/website.com/website.com/plugins/content/bot_facileforms.php on line 41

index.php?name=com_facileforms&ff_name=SampleContactForm
"
This only happen only if BreezinForms plugin is enabled. I think that only what worked was front page, contact page and Breezing Form page. Other pages stopped to work and displayed the above error message.

There are other problems with form design which I would like to mention. But I think it should be probably in other thread than this.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Re:Missing Form workaround 13 años 6 meses antes #155

  • mathdeveloper
  • Fuera de línea
  • Junior Breezer
  • Junior Breezer
  • Mensajes: 20
  • Karma: 1
  • Gracias recibidas: 0

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Re:Missing Form workaround 13 años 6 meses antes #175

  • Autor del tema
  • TheMuffinMan
  • Invitado
  • Invitado
as of version 1.5.1 b1 (build from 5/4/2008) this bug is fixed.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Re:Missing Form workaround 13 años 6 meses antes #204

See www.crosstec.org/forums.html?func=view&id=140&catid=5

I removed JParameter and it started to work without problems.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Última Edición: Post by pavn.

Re:Missing Form workaround 13 años 6 meses antes #206

TheMuffinMan wrote:

as of version 1.5.1 b1 (build from 5/4/2008) this bug is fixed.


I upgraded to 1.5.1 b1 and it displays:
Fatal error: Class 'mosMenu' not found in /var/www/web5/website.com/website.com/components/com_facileforms/facileforms.php on line 120

I also tried to reinstall to version 1.5.1 b1.

Still the same problem.

The best version which worked for me was 1.5.1 b with removed JParameter from function. It worked without problems for me.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Moderadores: ForumSupport
Tiempo de carga de la página: 0.057 segundos