TEMA:

Re: Adding Videos (self-hosted, youtube, vimeo, etc.) 10 años 11 meses antes #68879

  • bremnerr
  • Fuera de línea
  • Navegador Junior
  • Navegador Junior
  • Registered
  • Mensajes: 27
  • Gracias recibidas: 2
Well, I will be using the JWPlayer that is included in the CBVideo package for playing self-hosted videos. Thank you for the reply.

The player needs to be fixed to a particular size for every video in my library, even if this is done by changing a value in the jwplayer.js code.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Última Edición: Post by bremnerr.

Re: Adding Videos (self-hosted, youtube, vimeo, etc.) 10 años 11 meses antes #68943

  • Avatar de TheMuffinMan Autor del tema
  • TheMuffinMan
  • Fuera de línea
  • Administrador
  • Administrador
  • Super Users
  • Mensajes: 10377
  • Gracias recibidas: 838
Hi,

can you please tell me more about that fix and why you need it exactly? I ask because I am using the regular dimension settings already.

Regards,
Markus

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Re: Adding Videos (self-hosted, youtube, vimeo, etc.) 10 años 9 meses antes #71980

  • daniel_smit
  • Fuera de línea
  • Navegador Iniciado
  • Navegador Iniciado
  • Registered
  • Mensajes: 2
  • Gracias recibidas: 0
Hello there I am new to this and would like to test it out before I buy it to see if it works... I tried to impliment the embed feature but the plugin does'nt seen to be working so I tried the Iframe technique you posted and it shows the youtube player but it does'nt play do you know what else I need to do?

I copied this to the content prepare field:

$url = explode('?',$items["youtube"]["value"]);
$url = $url[1];
parse_str($url, $youtube);

$items["youtube"]["value"] = isset($youtube) ? $youtube : '';

and this is how my content template looks like:

<p style="text-align: -webkit-auto;"><span style="line-height: normal;"><br /></span></p>
<p>{hide-if-empty Battle_name}{/hide} {hide-if-empty Embed}{/hide}</p>
<table border="0" class="admintable adminlist" style="width: 100%;">
<tbody>
<tr class="row0">
<td width="20%" class="key" valign="top"><label>{Battle_name:label}</label></td>
<td>{Battle_name:value}</td>
</tr>
<tr class="row0">
<td width="20%" class="key" valign="top"><label>{Embed:label}</label></td>
<td><iframe src="
}" width="300" height="200" frameborder="0" allowfullscreen="true" title="{youtube:label}">
}" width="300" height="200" frameborder="0" allowfullscreen="true" title="{youtube:label}">
</tr>
</tbody>
</table>

I know I probably did something wrong do you maybe have any video tutorials on this except for the content builder introduction video on vimeo I am looking to create something exactly what your demo site shows here: contentbuilderdemo.crosstec.org/add-video.html

I have attached a screenshot on how it looks can you maybe give me some advice on that...

Thanks in advance
Adjuntos:

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Re: Adding Videos (self-hosted, youtube, vimeo, etc.) 10 años 9 meses antes #71981

  • daniel_smit
  • Fuera de línea
  • Navegador Iniciado
  • Navegador Iniciado
  • Registered
  • Mensajes: 2
  • Gracias recibidas: 0
The plugin is enabled I downloaded the video plugin link you provided and installed it....

crosstec.org/media/contentbuilder/plg_contentbuilder_video.zip

But seeing as I can't get it working I tried your way technique rather...

Thank you

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Re: Adding Videos (self-hosted, youtube, vimeo, etc.) 10 años 9 meses antes #72025

  • bremnerr
  • Fuera de línea
  • Navegador Junior
  • Navegador Junior
  • Registered
  • Mensajes: 27
  • Gracias recibidas: 2
RE:
can you please tell me more about that fix and why you need it exactly? I ask because I am using the regular dimension settings already.

Regards,
Markus


Sorry for the delay, I have been troubleshooting other issues. I have come to discover that the video size issue is related to Firefox and IE8. The video displays perfectly in Safari (except for strange fullscreen and volume button placement, see first attached photo), however, in Firefox. IE and Opera the video is is initially stretched vertically with fill bars on the sides, see second attached photo. In Firefox, IE8 or Opera I have to right click the video and choose "Stretching is fill" to get it to display properly.

Is there any way to get this to default to the "Fill" stretching? My visitors shouldn't have to right click and change this setting every time.

Many many thanks,
Ryan
Adjuntos:

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Última Edición: Post by bremnerr.
  • Página:
  • 1
  • 2
  • 3
Moderadores: ForumSupport
Tiempo de carga de la página: 0.063 segundos

Live Support Chat Opened!

Join our Discord chat here and enter the Crosstec channels to receive live support and talk directly to the team!