All my forms across several sites have this error on the SalesForce integration: UNSUPPORTED_API_VERSION: The API version that was specified (20.0) is below the minimum supported (21.0). Change the version number and run the request again.
This has just happened sometime in the last 48 hours. I'm running the latest version of Breezing Forms.
can you please check you PHP error log and provide to me full error message, or better you cand send me an error log, but tell me time and date when an error is occured
When a new version of Salesforce is released to Sandbox environments, the default API version of Salesforce is incremented in the Workbench API tool. This is not yet a valid option for Production environments, so if you attempt to log into Workbench with a Production or Developer org, this error can appear.
To correct this error, make the following changes in Workbench:
-Hover over the Workbench label
-Select 'Settings' in the dropdown
-Change 'Default API Version' to one version lower. For example, if the selected API version is 40.0 and you are receiving this error, change the API version to 39.0.
-Click 'Apply Settings' at the bottom of the page
-Select the Workbench icon in the taskbar from your org again, and it should now behave as designed
This option is saved in the browser cache. If you clear your cache or use an incognito browser, you will need to update this setting again.
Here's what the Salesforce rep said: we cannot set the version back. This is something that Salesforce has enforced and we have no control over it. The developer should be using API version 55.0 as that is the latest. Version 20.0 is very old and Salesforce no longer supports it
This is for a client, so I have no direct access to Salesforce. But I'm attaching a log and just did a test with a form that's still using the Salesforce integration (I turned it off on the main forms for now).