TEMA:

SalesForce Integration Unsupported API 20.0 8 meses 1 día antes #274770

  • Autor del tema
  • newhallklein
  • Fuera de línea
  • Navegador Iniciado
  • Navegador Iniciado
  • Registered
  • Mensajes: 8
  • Gracias recibidas: 0
All my forms across several sites have this error on the SalesForce integration: UNSUPPORTED_API_VERSION: The API version that was specified (20.0) is below the minimum supported (21.0). Change the version number and run the request again.

This has just happened sometime in the last 48 hours. I'm running the latest version of Breezing Forms.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

SalesForce Integration Unsupported API 20.0 8 meses 16 horas antes #274781

  • Avatar de Mirec
  • Mirec
  • Fuera de línea
  • Navegador Platino
  • Navegador Platino
  • Registered
  • Mensajes: 3262
  • Gracias recibidas: 161
HI,

can you please check you PHP error log and provide to me full error message, or better you cand send me an error log, but tell me time and date when an error is occured

When a new version of Salesforce is released to Sandbox environments, the default API version of Salesforce is incremented in the Workbench API tool. This is not yet a valid option for Production environments, so if you attempt to log into Workbench with a Production or Developer org, this error can appear.


To correct this error, make the following changes in Workbench:

-Hover over the Workbench label

-Select 'Settings' in the dropdown

-Change 'Default API Version' to one version lower. For example, if the selected API version is 40.0 and you are receiving this error, change the API version to 39.0.

-Click 'Apply Settings' at the bottom of the page

-Select the Workbench icon in the taskbar from your org again, and it should now behave as designed
This option is saved in the browser cache. If you clear your cache or use an incognito browser, you will need to update this setting again.

Maybe this help!

Let me know!

if you have more questions, feel free to ask!


Regards,
Mirko

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

SalesForce Integration Unsupported API 20.0 8 meses 10 horas antes #274803

  • Autor del tema
  • newhallklein
  • Fuera de línea
  • Navegador Iniciado
  • Navegador Iniciado
  • Registered
  • Mensajes: 8
  • Gracias recibidas: 0
Thank you for the quick response!

Here's what the Salesforce rep said:
we cannot set the version back. This is something that Salesforce has enforced and we have no control over it. The developer should be using API version 55.0 as that is the latest. Version 20.0 is very old and Salesforce no longer supports it

This is for a client, so I have no direct access to Salesforce. But I'm attaching a log and just did a test with a form that's still using the Salesforce integration (I turned it off on the main forms for now).

Here's a test page. If you fill out the form you'll see the error displayed. It also matches what I found in the log.
dcf.kadant.com/en/nforce-blade

Thanks again!

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

SalesForce Integration Unsupported API 20.0 8 meses 9 horas antes #274806

  • Avatar de Mirec
  • Mirec
  • Fuera de línea
  • Navegador Platino
  • Navegador Platino
  • Registered
  • Mensajes: 3262
  • Gracias recibidas: 161
Hi,

oke, I will take a look at it and see what we can do


I will back to you as quickly as I can

If you have more questions, feel free to ask!


Regards,
Mirko

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

  • Página:
  • 1
Moderadores: ForumSupport
Tiempo de carga de la página: 0.056 segundos

Live Support Chat Opened!

Join our Discord chat here and enter the Crosstec channels to receive live support and talk directly to the team!