Error 500 when sending form (but it is sent)

  • yeyyin
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1

yeyyin created the topic: Error 500 when sending form (but it is sent)

Hello,
We had installed a Pro version of last year and now only the free version on our website. (931)

We have a strange problem and we wanted to see if they can help us solve it or some clue to solve it.

If we publish the form in an article, there is no problem ;-)

But we have a file management component, in the description we are allowed to enter a form and it shows well, but when we press the SEND button, an Error 500 page appears. The second congratulation page is not shown nor the option to reload the page without error.
This message contains confidential information


The strange thing is that the form is sent. We only have the problem of error 500 when Breezingforms tries to return.

We enclose the error that shows our server logs.



If after seeing this error, they need access to the portal, say so.

This message contains confidential information


Thank you

regards

Diego Diaz
#234903
Attachments:
  • Posts: 5958
  • Karma: 119
  • Thank you received: 554

MarioPuco replied the topic: Error 500 when sending form (but it is sent)

Hi,

Okay I understand the issue.
Can you share your php error log please ?
Also we can try to install BF PRO on your site just to check if this will resolve the issue....
Let me know.

Regards,
Mario

Satisfied with our Support ?
PayPal Tip
===============================================
Need to renew Pro Support?
Buy Here!
===============================================
Satisfied?
Consider a membership!
===============================================
Like us on Facebook
===============================================
#234904
  • yeyyin
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1

yeyyin replied the topic: Error 500 when sending form (but it is sent)

Hi Mario,
I show you what appears when activating PHP errors in Joomla:
Warning: require_once(/var/www/vhosts/pepri.es/httpdocs/libraries/joomla/document/html/renderer/head.php): failed to open stream: No such file or directory in /var/www/vhosts/pepri.es/httpdocs/templates/eventus/error.php on line 27

Fatal error: require_once(): Failed opening required '/var/www/vhosts/pepri.es/httpdocs/libraries/joomla/document/html/renderer/head.php' (include_path='.:/opt/plesk/php/7.1/share/pear') in /var/www/vhosts/pepri.es/httpdocs/templates/eventus/error.phpon line 27
This message contains confidential information


I also attach the server error log file and the apache log file.

Thanks for all.

PD: I have tried https://www.joomdev.com/forum/jd-dallas/1180-solved-php-warning-no-such-file-or-directorythis possible solution , but the only thing that happens is that the error 500 disappears and an error 403 is shown.

File Attachment:

File Name: error_log.zip
File Size:31 KB

File Attachment:

File Name: error_log.1.gz
File Size:452 KB
#234915
Attachments:
  • Posts: 5958
  • Karma: 119
  • Thank you received: 554

MarioPuco replied the topic: Error 500 when sending form (but it is sent)

Hi,

By looking at your error log I can see that:
error 'PHP message: PHP Warning: escapeshellcmd() has been disabled for security reasons in .../libraries/vendor/phpmailer/phpmailer/class.phpmailer.php on line 1444\nPHP which could be a lead on resolving this issue as you can enable this:

So if you can re-enable escapeshellcmd() and test the form that would be great.

---

Please try to run the form in iFrame and see whether it changes anything ?

If you're linking your form directly with the Menu Item, please do the following:
Go to the Menu Item > Add Form tab > Run in iframe > Yes.

If you're embedding the form inside an article, please do the following:
Go to Extension > Plugins > BreezingForms > Use IFrames > Yes.

Also I think you will need to set your iFrame height to 100% so your form is rendered properly.
Go to your forms Advance Options > More Options > Autoheight iFrame and set it to "on" + set the width to 100% also.

Let me know if any of this helped.

Regards,
Mario

Satisfied with our Support ?
PayPal Tip
===============================================
Need to renew Pro Support?
Buy Here!
===============================================
Satisfied?
Consider a membership!
===============================================
Like us on Facebook
===============================================
#234920
  • yeyyin
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1

yeyyin replied the topic: Error 500 when sending form (but it is sent)

Thanks Mario, it has worked changing the parameters you mention to iFRAME.

About escapeshellcmd I did not need to do it (in fact I think that I had not done anything voluntarily before).

The 500 error is no longer displayed. Now the form looks different. Is there any way for the labels to be placed on the left again? I force the options "to the left", but it is placed above.

It does not matter much either, only if it's easy ;-)

Thank you for everything, we will buy again the update to PRO.

regards

Diego
#234924
The following user(s) said Thank You: MarioPuco
  • Posts: 5958
  • Karma: 119
  • Thank you received: 554

MarioPuco replied the topic: Error 500 when sending form (but it is sent)

Hi,

I'm glad that this helped.
Obviously there is a JS confilct with BF and you template and that's why Iframe solution works. Glad it's all working now.
Also if you want to add CSS to Iframes please try this : crosstec.org/en/support/online-documenta...css-for-iframes.html

Let me know if you have any other questions.

Regards,
Mario

Satisfied with our Support ?
PayPal Tip
===============================================
Need to renew Pro Support?
Buy Here!
===============================================
Satisfied?
Consider a membership!
===============================================
Like us on Facebook
===============================================
#234928
Moderators: ForumSupporttomeperica
Time to create page: 0.197 seconds

New Icon Packs Category!

Crosstec is now offering icon packs.

If you are a paying subscriber, icon packs are automatically added to your account.

Check out our icon packs page!

Live Support Chat Opened!

Join our Discord chat here to receive live support and talk directly to the team!

Summer Sale!

50% discount on all of our extension subscription plans, templates and icon packs!

Get Your Subscription Here

News and Updates

Get informed about new downloads, updates and more in our News and Updates newsletter.

All Extensions Subscription

Get 1 year access to all of our current and future products and 1 year of professional support -- 99 for just 49! (Summer Sale)

No support per domain or website installation limits! Includes all of our current and future Joomla!® extensions, Joomla!® templates for the duration of your membership. This means, by purchasing an All Extensions Subscription you'll have it all covered!

Get it from here

3rd Party Discount - 25% Off

We help you to keep your costs under control. If you are a new member and purchased a form building tool from a different form vendor, then you'll get a 25% discount on our subscription plans.

How to receive the discount:

Send us a quick email to sales@crosstec.org with a proof of purchase (for example a paypal receipt), await payment instructions and enjoy your membership!

Live Support Chat Opened!

Join our Discord chat here to receive live support and talk directly to the team!

Community Reward

Help us to create new extensions and plugins! With only $5 you help us a lot and get unlimited download access to all of our products, professional support and even more. Get your reward now!

Read More Here