TOPIC:

Component installation fails? 13 years 11 months ago #3368

  • Topic Author
  • TheMuffinMan
  • Visitor
  • Visitor
If you have timemout errors on installation (maybe also a white screen) then it is likely that you don't have native zip support installed and/or activated with your php installation.

If you encounter this you can ease your life by enabling it in your php.ini or if you are admin, install it if is not already installed.

e.g. for Windows machines using XAMPP it would be removing the ";" in the php.ini

;extension=php_zip.dll

If you do not activate this, Joomla! uses an alternative way of unzipping wich seems to be a lot slower AND additionally has a bug.

For alternative installation method, if you cannot somehow change the php.ini, see the instructions below.

############### Alternative installation (w/o the zip) #######

- unzip the com_breezingforms_151.zip and upload the directory within via ftp where joomla is installed (best would be JOOMLAROOT/tmp/ folder)

- then in the install panel, instead of using the upload field, enter the FULL server path into the second field (JOOMLAROOT/tmp/com_breezingforms_151)

- then hit install.

JOOMLAROOT = the full path to your joomla installation wich you have to find out first.


################

EDIT:

just got the answer from the dev team what is happening there (extraction).

"If you don't have server support we do our best to do it but it is
nowhere near as efficient as the server supported method. There is
also issues with zips within zips as well using our method because the
child's zip header gets incorrectly decoded into the parent's, there
should be a tracker item for it somewhere. It isn't an infinite loop
situation, because it will bail out with an error, its just trying to
extract every single zip file it finds (which is a bug)..."


So it is in fact a bug within Joomla! + slow routines of the alternative unzipping. What I am about to do now is to seperate several libraries into external plugins for the next upcoming version of BF.

The current package one can purchase includes a second component that lacks of the community forms feature but with this one you shouldnt get the error.

After all I try to find out if it is possible to fix that problem within Joomla! and send them a patch.

Regards,
Markus

Please Log in or Create an account to join the conversation.

Last edit: Post by TheMuffinMan.

Re:Component installation fails? 13 years 11 months ago #3440

  • Claude
  • Visitor
  • Visitor
i'm sorry, i made as you told
same result
XML file missing

cgu@mairie-quimper.fr

Please Log in or Create an account to join the conversation.

Re:Component installation fails? 13 years 11 months ago #3442

  • Topic Author
  • TheMuffinMan
  • Visitor
  • Visitor
did you really try this? cause this always works:

- unzip the com_breezingforms_151.zip and upload the directory within via ftp where joomla is installed (best would be JOOMLAROOT/tmp/ folder)

- then in the install panel, instead of using the upload field, enter the FULL server path into the second field (JOOMLAROOT/tmp/com_breezingforms_151)

- then hit install.

JOOMLAROOT = the full path to your joomla installation wich you have to find out first.

Please Log in or Create an account to join the conversation.

Re:Component installation fails? 13 years 11 months ago #3468

  • mschnyde
  • Offline
  • Fresh Breezer
  • Fresh Breezer
  • Posts: 3
  • Thanks: 1
I have the same Problem:

Trying to install 1.5.1 stable on an existing 1.5.1 RC1.

First, upload Package File failed and even the manual way "Install from Directory" failed.

Component Install: Another Component is already using directory: "/home/gaga4/public_html/joomla15/components/com_facileforms"

Component Install: Another Component is already using directory: "/home/gaga4/public_html/joomla15/administrator/components/com_facileforms"

:(

I have Joomla 1.5.8 and normally no problem to install any Components, Modules or Plugins, except BreezingForms


Any hints?
The following user(s) said Thank You: wartime

Please Log in or Create an account to join the conversation.

Re:Component installation fails? 13 years 11 months ago #3473

  • Topic Author
  • TheMuffinMan
  • Visitor
  • Visitor
ok, before you continue you have to remove those previously installed facileforms folders.

first have a look in the components list and install breezingforms/facileforms OR if it is not listed remove these directories via FTP: "administrator/components/com_facileforms" and "components/com_facileforms".

then send me an email to markus.bopp@crosstec.org and you will get a package that I have zipped with linux. then try again.

Please Log in or Create an account to join the conversation.

Re:Component installation fails? 13 years 11 months ago #3511

  • Jim Cannon
  • Visitor
  • Visitor
Hi,
I am having the same trouble described above and have tried the fix that you mention. Please assist me.
Thank you
Jim Cannon

Please Log in or Create an account to join the conversation.

Moderators: ForumSupport
Time to create page: 0.053 seconds

Quick Links

Downloads

BreezingForms

ContentBuilder

BreezingCommerce

Templates

Documentation

BreezingForms

ContentBuilder

BreezingCommerce

Apprendre BreezingForms (French Community)

Apprendre et maîtriser BreezingForms par des tutoriels et exemples, le tout en français

breezingforms.eddy-vh.com

Questions et réponses sur les forums de l'AFUJ

AFUJ

Special Offer

Sale! All subscriptions at a special price!

Includes prio support, all of our current and future Joomla!® extensions and Joomla!® templates for the duration of your membership.

Get it from here

3rd Party Discount - 25% Off

We help you to keep your costs under control. If you are a new member and purchased a form building tool from a different form vendor, then you'll get a 25% discount on our subscription plans.

How to receive the discount:

Send us a quick email to sales@crosstec.org with a proof of purchase (for example a paypal receipt), await payment instructions and enjoy your membership!